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Reminder

0 Presentation on Easel/ Create]S delayed until next
Tuesday

0 That presenter is at AdobeMax




Background -

0 Working with HTML for 21 years

0 Professor at Illinois Central College
0 Created first accredited AAS degree in Web Systems

0 We also have 5 certificates: web designer, web
developer, eCommerce, rich Internet applications,
webmaster

0 Director of Education at WebProfessionals.org
0 SchoolofWeb.org initiative

0 You will find a copy of these resources posted there
0 Adobe Education Leader (higher ed)




Brackets?

0 Tool for editing HTML, CSS, and JavaScript files
0 Written in HTML, CSS, and JavaScript
0 Extensible

0 Comes in two flavors

0 Brackets - open source (free) @ Brackets
0 http://download.brackets.io/

0 Edge Code - part of Creative Cloud P e o e
0 Extended with Adobe specific enhancements F—

0 Will discuss more when covering web fonts today




Brackets vs. Edge Code
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So what?

0 I teach web design and development

0 Beginning students don’t need to know Dreamweaver
0 They need to know HTML and CSS

0 Dreamweaver will help their productivity
after they know the basics

File Edit Search View Encoding Language Settings Macro

Run Plugins Window ?
dEHHB e--e@]lﬁ‘ﬁjlﬁl@c‘nﬁlg%lﬁg =

0 Think of Brackets as a replacement for: ..
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Basic Student Process

0 Create HTML/ CSS in Notepad or Text Wrangler...
0 Save file

0 Open browser, point to saved file

0 Doh?

0 Use debug tools to identify problem

0 Modify HTML/ CSS in Notepad or Text Wrangler...
0 Save file (again)

0 Refresh (or reopen browser)

0 Doh?

0 Lather, rinse, repeat




Basic Student Process

0 Student focuses on process (painful after time)
0 Brackets - live preview
0 Brackets on one side, browser on other side

0 Make a change to code in Brackets and immediately see
change in browser

0 Now student can focus on learning HTML and CSS
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File Edit View MNavigate Debug Help

1 <ldoctype html>
2 <html>

<head>

<meta charset="utf-8

5 <title>Responsive Text Columns</title>

<style type="text/css'">

8 body {
5 font-family:"Gill Sans"

MT", "Myriad Pro", "Deja
, Helvetica, Aria

17 #wrapper {
display:block;
margin-left: auto;
margin-right: auto;
width:90%;

#sidebar

m

. =
Responsive Text Col. % p

<« C i [[1127.0.0.1:53540/ResponsiveText.ntml OHEH## Qoo @ GhLa=

In this example, we have a couple of divisions and adjust their size relative to the available screen real estate (aka viewport). Make certain
you try this page on various devices or resize in a browser. Keep in mind the width of the containing wrapper division is 90%

s text defined in a This is the main content of the page. One might include a fair amount of lorem ipsum text to show
idebar. It will occupy the effect. In this case, | pulled the content from web20ipsum.com
2.1763598% of the
javailable screen real estate.
‘es, | chose this arbitrary

‘Webtwo ipsum dolor sit amet, eskobo chumby doostang bebo. Airbnb akismet imeem jaiku
eduvant scribd elgg woopra zohe, geni geyno ning yuntaa orkut joukuu chumby zinch, wesabe
number: Keep in mind the doostang jaiku hipmunk stypi vimeo mog imvu. Greplin gooru joukuu babblely convore whrrl
division occupies 90% of thed2Yn0 Mog zimbra plickers chumby heekya kno napster, groupon insala convore yammer cloudera
peal c=tater. [herelore, we airbnb heroku lijit mog disqus skype. Kaboodle flickr napster doostang blyve twones waze unigo
are using 19.95872382% = Waze flickr zooomr jiglu plaxo, plugg rovio imeem shopify reddit doostang nuvvo cotweet disqus
2.1763598% * 90%. The prezi napster plaxo glogster, sifteo odeo appjet hulu hipmunk jabber dopplr joyent napster stypi

ontent on the right will kosmix.

occupy the remaining
77.8236402% of the 90%.
es, browsers handle such

Handango groupon plickers kosmix convore cotweet odeo blyve bebo greplin, whrrl spotify ideeli
nuvvo yammer fleck vimeo lijit octopart, blippy cloudera twones whrrl jume jibjab zimbra spock.

2 5 — Lala bitly udemy trulia yammer mobly octopart blekko yuntaa, heroku hipmunk lanyrd geni mog
e dopplr ebay gooru, mzinga yuntaa sifteo nuvvo flickr weebly tumblr. Zoodles mobly kaboodle

USRI  R divvyshot mobly balihoo elpg plugg blyve yammer, yoono dropio blekko zoho loopt diigo zoosk

SsUp e O e e shopify. Jajah joost babblely balihoo jajah airbnb meevee, qeyno sifteo insala unigo ning twones

pfisctof aecond ool meevee, mzinga prezi zlio whrrl joukuu.
land show what happens
hen the page is resized.  Zappos eduvant omgpop xobni jibjab unigo revver kno balihoo iftit, bitly edmodo appjet mobly
groupon grockit heekya kno disqus squidoo, kaboodle joukuu wikia heroku shopify twones jaiku
ulia. Odeo loopt oovoo wakoopa diigo wikia tivo zoho, kosmix mobly vuvox squidoo zoosk
[zimbra flickr, greplin twitter empressr plugg foodzie dopplr. Joukuu boxbe chegg blippy kiko
eskobo balihoo heroku ebay hulu blekko boxbe zillow revver unigo zlio, greplin jajah mozy
convore udemy trulia zoho mobly sclipo lijit knewton orkut hipmunk. Palantir cooooc ngmoco

gsnap zanga blyve, orkut doostang joyent yoono.




Brackets Interface

0 Minimal (by design)
0 File > New

—_—

‘ ;;l.Example.htrnI - Brackets

File Edit View MNavigate Debug Help




Keyboard Shortcuts

0 Ctrl + Shift + o
|quick open file]

0 Ctrl + e [quick edit]

Quick Open: ||

[n this examp

isions and adeemplenm
the availablecfsmehtn

ResponsiveText.html

\"Ipo rt) . Ma ke ResponsiveText html

/arious devic

=. —= .= al- -

T Tt - - T =T rr

<div id="wrapper">
16

#wrapper {
display:block;
margin-left: auto;
margin-right: auto;
width:90%;

}

<div id="sidebar">

#wrapper ResponsiveText.html: 16




Keyboard Shortcuts

0 Ctrl + k [quick docs]

29 float:left;

float right
Elements which get float applied The right value indicates that the element must float to the right side of its
with a value other than none are containing block.
taken from the normal flow and left
get wrapped on the left or right =
side of the parent element. Other The Left value indicates that the element must float to the left side of its
elements get wrapped around it. containing block.
none

none indicates that the element does not contain any float at all. This is the
initial value of the float property.

‘ A Read more ‘

0 Read more takes you to:
http://docs.webplatform.org/wiki/css/properties/float




Brackets Extensions

0 Extensible
0 Help > Show Extensions Folder

0 https://github.com/adobe/brackets/wiki/Brackets-
Extensions

0 Store zip file locally

0 Extract contents into extensions folder
0 Reload Brackets
0 For example - HTML templates extension

0 When create file...
0 Edit > HTML Templates




HTML Templates

0 Choose from list

' Example.html - Brackets

File. Edit View MNavigate Debug Help

HTML Templates

Choose a doctype...
HTML5

HTML4 Transitional

HTML4 Strict

¥HTML 1 Transitional

KHTML 1 Strict

XHTML1.1




HTML Templates

0 Starting HTML5 document
0 Again, let students focus on learning, not process

F ;;! » Example.html - Brackets Q‘@u

File Edit View MNavigate Debug Help
D 1 <ldoctype html> e
e 2 <html>
3 <head>
4 <meta charset="UTF-8">
Bra tx 5 <title>Untitled Document</title> |

W N

</head>
<body>

-] & N1

— @ W

</body>
</html>

l_l' t_! !_.'
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Extensions

0 Show Shortcuts - <!doctype html>

. . <html
built in as of <he2d;

| <meta charset="UTF-8">
e - <title>Example Brackets

View | Navigate Debug Help Document</title>

Hide Sidebar Ctrl+Shift+H </head>
<body>

Increase Font Size Ctrl++
Decrease Font Size Ctrl+-
Restore Font Size Ctrl+0

Line 4, Column 5 * 12 Lines HTML Spaces 4

Highlight Active Line Shortcuts

Copy to Current Document

Line Numbers Base Key Key Binding Command ID Command Name Origin

Word Wrap Ctrl+ view.increaseFontSize Increase Font Size Brackets
Enable JSLint - Crl— view.decreaseFontSize Decrease Font Size Brackets
Enable Hover Preview Ctrl-/ editlineComment Toggle Line Comment Brackets

Enable W2CValidation Ctrl-Shift-/ edit.blockComment Toggle Block Comment Brackets

Enakle BracketLESS Ctrl-0 view.restoreFontSize Restore Font Size Brackets

Ctrl-= view.increaseFontSize Increase Font Size Brackets
Ctrl-A edit.selectAll Select All Brackets
Ctrl-C edit.copy Copy Brackets

Show Shortcuts
show CanlUse
Enable CSSLint

Cerl-Shift-C file.previewHighlight Live Highlight Brackets
Ctrl-D edit.duplicate Duplicate Brackets




Extensions — CanlUse

¢ CanlUse - inline version of CanlUse.com site

1\.f'ie'nr\.r] Mavigate Debug Help

Hide Sidebar Ctrl+Shift+H

Ctrl++
Ctrl+-
Ctrl+0

Increase Font Size
Decrease Font Size
Restore Font Size

Highlight Active Line
Line Mumbers
Word Wrap

Enable JSLint

Enable Hover Preview
Enable W3CValidation
Enable BracketLESS
Show Shortcuts

Show CanlUse

Enable CSSLint

<form>

<input type="number" />
</form>

CanlUse

CSS

@font-face Web fonts
C553 Multiple backgrounds
C553 Border images

F

C553 Background-image options
C55 Table display

C55 Generated content

C55 position:fixed

C55 2.1 selectors

C553 selectors

C553 Text-shadow

C553 Box-shadow

C553 Colors

£SS3 By cizing

N Lum ber In p‘ut type (Support: 34.83% / Partial Support:

5.779% / Total: 40.60%)

B -5upported [ = Mot supported
= Support unknown

IE Firefox Chrome  Safari

Previous

Current

= Partially supported

Opera 05  Android

4.2-
4.3




Extensions - Validate

0 W3C validator - code should validate

View | Navigate Debug Help <body>
<h1></p>

Hide Sidebar Ctrl+Shift+H

Increase Font Size Ctrl++
Decrease Font Size Ctrl+-
Restore Font Size Ctrl+0

</body>

Highlight Active Line </html>
Line Numbers

Word Wra
P W3acCValidation

Enable JSLint
. _Enable Hover Preview
Enable W3CValidation

enable Bracketless Contexts in which element  Element p not allowed as
Show Shortcuts p may be used: child of element hl in this
Show CanlUse Where flow content is context. (Suppressing

Enable CSSLint

Line Explanation Message

B = Neo p element in scope but a

p end tag seen.

expected. further errors from this

subtree.)




Extensions - Hover

0 Hover preview - quickly see images/ colors

View | Mavigate Debug Help
Hide Sidebar Ctrl+Shift+H

Increase Font Size Ctrl++

Decrease Font Size Ctrl+- float:

Restore Font Size Ctrl+0 }

Highlight Active Line

Line Numbers #content {
Word Wrap width:77.8236402%;

pEpabletalint background-color:
Enable Hover Preview CD-LD e

Enable W3CValidation float:
Enable BracketLESS
Show Shortcuts
Show CanlUse
Enable CSSLint

b




Extensions - Fonts

0 Fonts - add fonts to page — Brackets relies on Google fonts,
Edge Code on Edge Web Fonts

0 Edit > Web Fonts...

0 For Brackets, need to include following line at top of CSS
file

@import url(...);




Extensions - Fonts (2)

0 Visit http: //www.google.com /fonts/ to choose font(s)

@import
url(http://fonts.googleapis.com/css?family=Antic|Abril
+Fatface|Aclonica|Caesar+Dressing);

Web Fonts

Add Font

Example Text

D antic ) Abril Fatface () Aclonica '-.T.-'CaesarDressing

Swap Fonts Delete Font




Extensions - Fonts (2) CO

0 Edge Code has better integration with Edge Web Fonts

Adobe Edge Web Fonts

p{
font-family:l |

m
=

owse for and select the web font you wish to include in your web projec

Aa Aa Aa

M o

AA Aa Aa

Alegreya 5C

I=HIZZIEL

Ha AR An

—

e Web Fonts Terms of Use ﬁ




Extensions - Fonts (3) CO

0 After selecting font, click on WF logo to generate HTML
code

Adobe Edge Web Fonts

Edge Web Fonts are loaded into the user's browservia JavaScript. To ensure thatfonts

are properly loaded, you must add a script tag to your HTML.
Copy the following script tag and paste itinto all HTML files that reference this CSSfile:
script=var __adobewebfontsappname__ = "code"</script=

script sre="hitp://use.edgefonts.net/chicleind:all.js"=</script:

Edge Web Fonts Terms of Use

0 One instance where Edge Code better integrated




Extensions — Lorem ipsum

0 In case need placeholder text

0 Alternate installation - File > Install extension...

Install Extension

Installation successful!

Close

0 While typing text, enter lorem followed by tab key

T¢ GLSMOD NAM QUAMQUAM iN OFFENDIT ARBITRANTUR 3¢ PROIDENT, QUIBLSDAM VELIT QUAMQUAM O<CACCAT, ViDisse VENIAM OFFiGA
MENTITUM A iD € FiRMisSiMUM, AMET €X<CPTCUR ARBITRANTUR, A iPSUM iD LABORE Hi¢ iTA LABORE €iLSMOD OCCACCAT. Hid €LIT <¢RNANTUR
iUDICEM, AUT ¢ VENIAM €XPETENDTS. INCURRERET LOREM AUTE COMMODO NOSTER, VOLUPTATE QLD QUis ¢ GLLUM, POLOR TEMPOR QL
SEMPITCRNUM €X €53¢ OCCACCAT NON LABORIS. Vibiss¢ MULTOS LABORE NAM FORE, SUNT POSSUMUS € SUNT €NiM, €T VENIAM PRAGENTIBLS €T
€LiT COMMODO T Nisi VARIAS Hi< PARIATUR AN OFFiGA €A AD €NiM OFFIGA iD iNCURRERET QUi GiLsMOD i €X QUAC Fib¢LissiMAC E D

CONTUNCTIONS. UBi ALIQUA COMPREHENDERIT T4 €U ALIQUA €55¢ FUGIAT QLIBUSDAM. VENIAM MENTITUM AD iNGENiTS, N€ 5€D FAMILIARITATEM, ¢
PARIATUR iNSTITUCNDARUM, $i NON FUGIAT <ULPA SUNT.




(4]

Demo - using MUSE
Export files




Review

0 Brackets is an editor for HTML, CSS, and JavaScript

0 It is highly extensible (and there are already a number of
developed extensions)

0 It is open source (free)

0 There is a corresponding Adobe product (Edge Code)




Thought
0lItis 2013

JavaScript Development cycle

This is an overview of how we typically develop client side seripts,

Typically, we create our initial file {(either
within the existing HTML document or as a
separate js file). We create the code and
save the file

If we are returning from a testing session, we
modify the code we already created and

repeat the process by testing in the browser
again (until we are satisfied with the reuslis).




Resources

0 http://brackets.io/
0 http://download.brackets.io/
0 http://markdubois.me/Brackets01 (project overview)

0 http://markdubois.me/Brackets02 (getting started with
Brackets)

0 http://schoolofweb.org (these materials and recording)

0 My weblog posts on Brackets
0 http://markdubois.me/Brackets03 (sprint 20)
0 http://markdubois.me/Brackets04 (sprint 10) my initial

thoughts




Adobe Brackets

0 http://download.brackets.io/

0 Questions?
Please use question pod

@Mark_DuBois (Twitter)

Mark@WebProfessionals.org




Slides

http://markdubois.me/2013May7
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